Home > IT, Solved problems > One or more ActiveX control could not be displayed

One or more ActiveX control could not be displayed


one or more contro 

 

Recently my computer does not want to open Services and gpedit.msc. When I open any activeX control object it raised an error “one or more activex controls could not be displayed because either…”

I was confused if I could have any virus on my pc. I have bitDefender 2010 and changed the antivirus mode to aggressive to pull all malwares. I love bitDefender as it is very simple and includes powerful Firewall  but since the error occurred  I could not even open bitDefender Dashboard as bitDefender 2010 version also used ActiveX control.

I thought the aggressive mode of bitDefender blocked the web contents and the activeX control so I wanted to disable bitDefender and give a try.

 

before I disable BD I searched on google and seen many people had the same problem and some of them were resolved when they changed some Registry key in RegEdit.

Microsoft announced changing registry key

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

key : 1200

Value either 1 or 2 might overwrite 3

I have tried this but still NO luck.

I thought my internet explorer has bug and installed Internet Explorer 9 beta to overwrite all local setting.

Still no luck..

 

I created another admin useraccount and opend Services.msc  and it was working fine. It must be something with my current userprofile and not current local machine.

I thought I can create a new user account and move all my stuffs to the new user account but it will be too much for me and most of my settings and mails has to be reinstalled again and I didn’t want to do that.

Two days are gone, I didn’t had much time to sit front of computer and the problem was still there. I searched in google again this time with additional key word

“one or more activex controls could not be displayed because either…” Service

and found some interesting pages.

One of the page said to delete an extra key in registry will resolve the problem and I was excited.

I opened registry and deleted the extra key “L” in

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

Delete key and subkeys : “L”

 

and pressed F10 to refresh the registry. Voila…..

The error message are gone.. i could access gpedit.msc as well as services…

 

I was not satisfied with my progress and I wanted to know what caused or what action created the extra key in registry.  I reversed my mind  to past two days and realised I downloaded a keygen from internet.

Usually I don’t trust any keygen.exe files from internet except if they are included with software but I wanted to give a try as I didn’t find serial for my searched software Winking smile

 

as soon as I downloaded the keygen.exe I expected my BD will raise any virus alert as it always does. but this time i didn’t get any alert so i thought the keygen could be trustable.

I opened the keygen and suddenly my BD raised alert box that it blocked may viruses in my TEMP folder.

 

I realized the keygen was intelligent enough to hide the virus in it and tried to exploit my pc with many worms in system folders. BD blocked the virus and deleted still i wasn’t happy as my sidebar gadGage showed Processor level to 80%

I have AMD phenom IIII with 4 cores with nearly 9GHz speed and I never seen my processor 80% in all 4 cores.

I opened my taskmanager and checked CPU activity and found 3 of new .exe files were causing 50% of my CPU. I opened the location of the files and deleted manually.

on top of that I have changed my antivirus mode to aggressive to scan everything including web traffic.

The virus I recently downloaded changed my internet explore proxy settings and created a new key in registry to bypass the local activeX settings.

The target was to disable all activeX contained objects and forward all internet traffic through a local proxy.

This will cause whenever I want to go to internet it will open many popups as it want with some porn websites and other malware websites.

I don’t use internet explorer Chrome and mozilla are my favourite sadly chrome uses local internet settings from internetExplorer including proxy and other connection settings.

 

No I have solved the problem after two days of hitting my head on the wall Winking smile

and realized what caused the problem.. next time.. I know what to do if my friends asking me if they experiencing same symptoms.

 

and that’s how I learn IT…

 

 

Windows Live Tags: ActiveX,computer,Services,error,virus,mode,Firewall,Dashboard,version,contents,Registry,RegEdit,Microsoft,HKEY_CURRENT_USER,Software,CurrentVersion,Internet,Value,luck,explorer,Still,admin,machine,user,account,Service,Delete,Voila,message,action,files,TEMP,folder,system,Processor,IIII,location,traffic,proxy,objects,Chrome,connection,friends,viruses,symptoms,gpedit,bitDefender,antivirus,google,overwrite,didn,keygen,websites
WordPress Tags: ActiveX,computer,Services,error,virus,mode,Firewall,Dashboard,version,contents,Registry,RegEdit,Microsoft,HKEY_CURRENT_USER,Software,CurrentVersion,Internet,Value,luck,explorer,Still,admin,machine,user,account,Service,Delete,Voila,message,action,files,TEMP,folder,system,Processor,IIII,location,traffic,proxy,objects,Chrome,connection,friends,viruses,symptoms,gpedit,bitDefender,antivirus,google,overwrite,didn,keygen,websites

Advertisements
  1. Vahid
    January 16, 2011 at 10:45 am

    Thank you, it really helps me, it seems you learn IT well 😉

    Like

  2. sunil
    January 21, 2011 at 3:15 am

    hai..buddy it din’t work out…m using windows7 and mozila latest3.6

    let me see if i can get smething wll update u

    Like

    • January 21, 2011 at 4:03 am

      Hii sunil,

      Remember I have tried both options. 1. Change the value of key 1200 to 1 (if already 1 try 2 than refresh than try again 1)

      2. Delete ALL sub keys in \zone\ except 0.. 4

      3. Did also reset my internet explorer settings..

      Lemme kno if it helps

      Krish j

      Like

      • BGM
        May 21, 2011 at 1:07 am

        Hello! Thank you, xkrishnax, I found a key in zones whose name was a square – in other words, some kind of character that couldn’t display. I deleted that key as per your recommendation (delete ALL sub keys in zone except 0…4) and it worked! Thank you!

        Like

  3. January 21, 2011 at 11:24 am

    Thanks friend and it worked very nicely ,, and thank you very much

    Can you remember those .exe names ???

    KIT

    visit >>>>>>>> http://ticbit.wordpress.com/

    Thanks

    Like

    • January 21, 2011 at 12:00 pm

      mhhh I cant remember the .exe files, but I’m sure they were running in
      %Userprofile%\AppData\Roaming\ somewhere.

      Open you taskmanager sort by CPU speed. look for any .exe
      that doesn’t has description
      has random name
      causing CPU process
      has the description same as the .exe file

      these are the files that usually “unauthorized” one ;))

      Like

  4. Rossi
    January 21, 2011 at 7:34 pm

    I was getting frustrated reading bitdefender forums on this problem(all suggesting to install bitdif 2011) but I like the 2010 version and wanted to stick to it.
    This is great solution.
    I really appreciate the way you have thought about it.
    Keep it up!
    Your solution deserves more publicity

    Like

  5. sumeet
    April 10, 2011 at 8:07 am

    you r one genius …it actually worked..thx buddy..i have got one more query ..my windows security it always come with flag with a red cross …secondly when i try to restart the services for security centre…it enables for a while but again it gives me the same error..i am using Mcafee security software…help me !!

    Like

    • April 10, 2011 at 10:13 am

      This symptom has many triggers, either the security centre is telling you, your AV is not updated version of its series, you update is not enabled OR your firewall is switched off.

      I don’t use McAffe, most of the Antiviruses switch the default windows firewall of to avoid conflict and take full control of traffic. In this action the Antivirus has to tell to the windows “I’m an updated version of my provider, you can trust me”. The windows security centre than accepts the antivirus and allows switching off its default firewall. If your windows version knows there are another updated version of your current Antivirus it will throw an error message “your AV is not current/ updated”.
      If it’s triggered by windows update action, select option “show updates let me choose whether to download or install”.

      If it’s triggered by antivirus, same applies as firewall. It just means Windows does not trust your current antivirus software.

      Btw.. you can’t have mcaffe firewall and windows firewall at the same time, mcAffe will try to switch off your default firewall and if windows doesn’t trust it will throw red flag message!

      Like

  6. Ali Mithai
    April 24, 2011 at 8:41 am

    Thnks Buddy…It Really Worked for Me….

    Like

  7. kolaiveriyan
    April 30, 2011 at 6:38 am

    its just simple as that, just d/l malware bytes . do a scan.. restart .. u r done with it.. it worked for me …

    Like

  8. May 21, 2011 at 7:29 pm

    BGM :
    Hello! Thank you, xkrishnax, I found a key in zones whose name was a square – in other words, some kind of character that couldn’t display. I deleted that key as per your recommendation (delete ALL sub keys in zone except 0…4) and it worked! Thank you!

    thank you!

    Like

  9. Danny
    July 13, 2011 at 12:32 am

    it woked tank you veeeeeeeeery much

    Like

  10. July 27, 2011 at 1:49 pm

    Thanks for the valuable information.

    Faced the same issue at my end.Followed the steps given on above link.

    http://am-techzone.blogspot.com/2011/07/one-or-more-activex-controls-could-not.html

    Like

  11. April 22, 2013 at 6:43 pm

    Hey! Do you know if they make any plugins to safeguard against
    hackers? I’m kinda paranoid about losing everything I’ve worked hard
    on. Any tips?

    Like

  12. April 9, 2014 at 5:21 pm

    I think this is among the most significant information for
    me. And i am glad reading your article. But should remark on some general things, The website style is perfect, the articles is really
    nice : D. Good job, cheers

    Like

  13. April 12, 2014 at 4:29 am

    A fascinating discussion is definitely worth comment.

    I think that you need to publish more on this topic, it may not be a taboo subject but generally people do not speak about
    such issues. To the next! All the best!!

    Like

  14. August 28, 2014 at 2:17 pm

    I’m gone to say to my little brother, that he should also visit this
    web site on regular basis to obtain updated
    from latest gossip.

    Like

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: